There was a problem loading the comments.

Kiesbare PHP versie

Support Portal  »  Knowledgebase  »  Viewing Article

Waarom kiesbare PHP versies?
Op een server kunnen verschillende sites staan0 sommige zijn nieuw en anderen wat minder nieuw.
Zo kun je de juiste versie op iedere site instellen.

Welke versie moet ik kiezen?
PHP houdt security updates bij voor de gangbare versies van PHP. Gemiddeld doen ze dit zo'n 2 jaar per versie.
Je kunt op de site van PHP zelf zien welke versies nog worden onderhouden met beveiligingsupdates
https://www.php.net/supported-versions.php

De meeste moderne website software kan overweg met PHP 7.4 en vaak ook al met PHP 8.0 en hoger. Wanneer blijkt dat de code van je website niet overweg kan met versie 7.4 adviseren wij om de code van de site te updaten zodat deze geschikt is voor PHP 7.4 en hoger. Vaak kun je ook op de site van het CMS zien welke versies worden ondersteund.

Mocht je een zelfgemaakte applicatie gebruiken die ontwikkeld is voor een oudere versie van PHP, raadpleeg dan je webdeveloper of het veilig is om te upgraden naar PHP 7.4 en hoger.

Hoe kies ik een andere PHP versie?
Via het controlpanel kun je de PHP versie van je site aanpassen.
Hieronder de stappen die je kunt nemen om een andere PHP versie te selecteren.

Stappen:
1. in te loggen op het control panel
2. in het linkermenu te kiezen voor websites.
3. Selecteer vervolgens de betreffende website.
4. Op de website pagina, staat een dropdown menu met de PHP versies die beschikbaar zin op de server waar de website staat.
5f2258fd2fb7deeba086342671bf45dd7c42748d1f6b83e957ed9a55b53ea2c201ac95479f789562?t=d15c92d383629f8a768de5f389322df5
Staat de staat de gewenste versie er niet tussen neem dan contact op middels een e-mail of ticket.


Mijn website doet het niet meer, wat nu?
Het kan voorkomen dat na het wijzigen van de PHP versie je website niet meer werkt, waarschijnlijk is de code van je website dan niet geschikt is voor een nieuwere versie van PHP.

Via de bovenstaande stappen kun je kiezen voor een andere versie van PHP.
Naast dat de applicatie niet overweg kan met de nieuwere PHP versies is de kans dat de site gehackt kan worden veel groter.
Zorg er dus voor dat je webapplicatie regelmatig wordt ge-update.
De oudere versies van PHP (7.2 en lager) zullen in de loop van de tijd worden uitgefaseerd omdat HostingXS de veiligheid niet kan garanderen als er geen security-updates meer worden uitgegeven.
De webapplicatie zal dus geschikt gemaakt moeten worden voor PHP7.3 en hoger.
Did you find this article useful?  

Related Articles

  1. Het maken van een .my.cnf
  2. Hoe plaats ik mijn website online?
  3. Soorten DNS Records
© HostingXS