Waarom kiesbare PHP versies?

Op het shared hostingplatform staan verschillende sites, sommige zijn nieuw en anderen wat minder nieuw. Tot voor kort werd de php versie van de server niet geupdate omdat er sites bij zaten die hier niet mee overweg kunnen.

Dit is nu aangepast en je kunt nu per website aangeven welke php versie je wilt gebruiken.

Dit is mogelijk voor alle standaard- en zakelijke hosting pakketten.

Heb je een eigen server en wil je een andere PHP versie, neem dan contact met ons op.


Welke versie moet ik kiezen?

Op 2 januari 2016 aangekondigd dat er geen wijzigingen en verbeteringen meer gedaan zullen worden aan PHP 5.6, maar ondanks dat zal de PHP versie nog met security updates worden ondersteund tot 31 december 2018.

De meeste moderne website software kan overweg met PHP 5.6 en vaak ook al met PHP 7.0 en hoger. Wanneer blijkt dat de code van je website niet overweg kan met versie 5.6 adviseren wij om de code van de site te updaten zodat deze geschikt is voor PHP 7.0 en hoger. Vaak kun je ook op de site van het CMS zien welke versies worden ondersteund.

Mocht je een zelfgemaakte applicatie gebruiken die ontwikkeld is voor een oudere versie van PHP, raadpleeg dan je webdeveloper of het veilig is om te upgraden naar PHP 7.0 en hoger.


Hoe kies ik een andere PHP versie?

Via het Controlpanel kun je de PHP versie van je site aanpassen.

Hieronder de stappen die je kunt nemen om een andere PHP versie te selecteren.


Stappen:

1. in te loggen op het control panel 

2. in het linkermenu te kiezen voor websites. 

3. Selecteer vervolgens de betreffende website.

4. Op de website pagina, kun met de blauwe actie knop kiezen voor wijzigen en krijg je de mogelijk om je php versie aan te passen.




Mijn website doet het niet meer, wat nu?

Het kan voorkomen dat na het wijzigen van de PHP versie je website niet meer werkt, waarschijnlijk is de code van je website dan niet geschikt is voor een nieuwere versie van PHP.

Via de bovenstaande stappen kiezen voor een andere versie van PHP.

Waarschijnlijk is de webapplicatie al een tijd niet bij gewerkt of verouderd.

Naast dat de applicatie niet overweg kan met de nieuwere PHP versies is de kans dat de site gehackt kan worden veel groter.

Zorg er dus voor dat je webapplicatie regelmatig wordt ge-update.

De oudere versies van PHP (5.5 en lager) zullen in de loop van de tijd worden uitgefaseerd omdat HosingXS de veiligheid niet kan garanderen als er geen security-updates meer worden uitgegeven.

De webapplicatie zal dus geschikt gemaakt moeten worden voor PHP5.6 en hoger.